This topic contains 9 replies, has 2 voices, and was last updated by  apocal1pse 19 hours, 43 minutes ago.

Google PageSpeed Insights

  • Are you thinking of doing some optimization to the theme in the future?

    I tried to test some of your examples in Google PageSpeed Insights and the average is (poor) 50/100 for mobile devices and (poor) 25/100 for desktops.

    With the addition of a few plugins, the values goes down even more and the websites will certainly be penalized by Google.

    I already tryed some cache plugins but with little improvement or else the website does not work very well because damage some plugins.

    Hi,

    Thank you for your suggest.
    In the next update of Soledad, we will add more lazyload images feature for fixed images issues with google page speed.
    For other issues on google page speed, you can use some plugins to make it pass.

    Best Regards,
    PenciDesign

    What plugin do you recommend to try?

    I already tried WP Super Cache, W3 Total Cache, Autoptimize and WP Fastest Cache with small changes in Google Speed Insights values

    Hi,

    Please wait when version 4.0 release and we will write a guide for how to optimize google speed score.
    As expected, big update ever version 4.0 will release in next month.

    Best Regards,
    PenciDesign

    Great! I’ll wait for that update!

    Thank you!

    Regards.

    Hi again,

    I already updated to v.4.0 and notice some changes, but the first image of each article takes longer to load that any other picture

    I see some “loading effect” while others load more quickly.

    Is that normal?

    Didn’t notice that in v.3.2.

    Hi,

    It’s lazyload for featured images on each post.
    You can remove loading effect on it by add more this code to Customize > Custom CSS:

    .container-single .post-image .penci-lazy[src*="penci-holder"]{ height: 0; }
    

    Best Regards,
    PenciDesign

    is it possible to disable all lazyload features?

    in my blog I’m using some long posts (can’t divide because I’m using Visual Composer in the blog), and the main (first) picture takes too long to load. Sometimes only loads when all post is visible (the other photos loads earlier then this one)

    I test some other Soledad Theme blogs and this “problem” is only visible in the 4.0 version

    It happens in this one http://www.mouseclick.com/2013/03/12/die-pille-danach/
    In this one too https://www.outandabout.be/carrick-a-rede-populairste-hangbrug-in-ierland/

    In this one, the main picture loads very fast (without the lazyload feature in 4.0) https://www.livingthebeauty.de/glossybox-juni-2017-salsa-summer-nights-edition/ (this blog has the 3.1.1 version)

    Can I disable completly this new feature of lazyload? Because for me it’s the only thing that doesn’t seams to work very well for 4.0 version

    If I remove the loading effect like you said, the image doesn’t load fast either, only the effect disapears but it takes the same time as the loading effect

    Cheers

    Hi,

    If so, please wait for next few days.
    We’re building the next update for this theme and it will release in next few days.

    Best Regards,
    PenciDesign

    Thanks you! :)

    I’ll wait

You must be logged in to reply to this topic.